Director names can't be imported if they contain an apostrophe ("O'Neill," etc.)

I come up against this longstanding problem all the time. I’ve started to just assume that whenever a mainstream-ish film has no director credit, it’s because the name contains an apostrophe. Furthermore, you can accidentally REMOVE a director’s name if you update the info for a film that already displays an apostrophied director. Whoops.

Hate this. :frowning:

Could you please try again. This bug should be fixed.

Let me know if it’s still not working

It seems to be working again! Hooray, thanks! I just bemoan COUNTLESS forgotten examples I’ve found of this problem that I was unable to correct at the time. :frowning:

Hrm. I did fix some Marcel L’Herbier films, but I still can’t get this director filled in:

Roscoe ‘Fatty’ Arbuckle now has about 25 more directing credits on ICM, thanks to me. :slight_smile:

I guess the problem isn’t entirely solved, because here are two recent films with apostrophe directors who won’t import.