Import IMDB ratings

Agreed. I used Excel initially but Microsoft is rather infamous for hidden formatting. Thus why I switched to Notepad. Usually Notepad is the most basic viewer/editor and strips out extra (hidden) formatting.

Didn’t think of it until just now, but I can go to the command line prompt in the underlying system and view the file. I’ve looked quite carefully and don’t see any extra characters. But I think I may have found something. (A missing character) Let me play around with it some more in a couple hours. I was just ‘checking in’ briefly.

Okay, we have a workaround! It turns out iCM needs a “/” at the end of the URL.

Here is what I did in Excel to get a file that imports into iCM just fine.

  1. Download ratings from IMDb
  2. Open the csv file in a spreadsheet program (I used Excel 2002)
  3. Sort the file in descending order by Date Rated (optional but ensures data is sorted for next step)
  4. (optional) Trim the file to a manageable size since iCM has an upper limit for importing. Since I know when I last imported my data into iCM, I deleted everything older than that
  5. Delete entire column E (Original Title)
  6. Make sure that the date fields are in the following format: yyyy-mm-dd
  7. In cell P2 enter the formula =CONCATENATE(E2,“/”) or whatever is the equivalent for your programme
  8. Copy P2 to all cells in the P column for rows with data
  9. Copy all cells in column P that have the new URL
  10. Paste Special/Values to E2 (note: while I haven’t tested to be certain, I believe column E needs to retain the header “URL” so I copy specific cells and not the entire column)
  11. Save the file retaining the csv format
  12. Upload to iCM as usual

That did the trick for me. I had missed one title during the past quarter and so the import checked that for me. I’d also unchecked a title I watched earlier in the day and importing checked it as well. So, while @Marijn might be able to fix this on the server side, at least anyone who wants to import ratings in the meantime now has a work around.

1 Like

Nice work xianjiro. :clap:

I didn’t even notice that the URLs in the csv file didn’t have the / at the end anymore. Nice catch. Strangely enough, the / still shows up in lists that are exported from IMDb. Wonder why they removed it from the ratings export. :person_shrugging:

@Runar Based on xianjiro’s findings, try this file and see if the import will work correctly for you:
import-new2.csv (944.4 KB)

Yes, that did work. Thanks! :slightly_smiling_face:

So hoping this will be fixed soon. At least there is a work around now.

1 Like

Any update to a fix on the backend instead of a workaround?

i also had to change the date format to

yyyy-mm-dd

I just double checked and my date fields export as yyyy-mm-dd. What was the format in your export file before changing it to yyyy-mm-dd?

edit: or could your spreadsheet program change the date format when you open the CSV or something like that? Did you have to change both columns? (Date Rated & Release Date)

edit 2: I’ve added a line to the workaround