Can’t add films to the database

Whenever I try to add a film to the iCM database in the beta it says it’s been added to the queue, but it doesn’t actually get added to iCM. In the past I’d receive a PM almost immediately saying it was added to iCM, but the PM doesn’t come through either.

The PMs stopped happening a year or two ago, I think, but the films should still be added. What I usually do after importing a film is go back in the browser and resubmit. It usually then tells me that the film was already imported and links to the new page. Do you remember a specific film you’ve recently tried to import?

You’re right that it does find it when I go back in my browser. And now I’m able to find the film by searching for it as well. Weird. False alarm, then. :sweat_smile:

1 Like

Also, they don’t seem to add right away. I usually wait a couple hours and then search again and then I can find it added to the site.

Normally they are added right away, but you can’t find them yet by searching with the title. This is useful though:

Couldn’t add this

Doesn’t seem to be adding for me either. Not sure if it’s specific to that film or some wider issue. I’ll see if I can check.

Edit: I tried to add a different film and it also didn’t go through, so I don’t think it’s film specific. I’ll check back later to see if it’s just a delay, otherwise @Marijn will have to check to see what’s happening.

Edit2: 2 hours later still nothing. It’s definitely an issue with the queue.

You’re correct. IMDb changed something in their page layout again. I’m on it.

Just pushed a fix, so adding movies should be working again.


The initial link is still unable to be added

Confirmed. I just tried it myself. Not sure why that one’s not going through but others did.

Marijn made some more changes and this went through now.

I’ve added it for you: